Printers offline in Digital Factory
Incident Report for Ultimaker
Resolved
The issue is now resolved. All printers have new firmware. If you are having trouble with your connection to Digital Factory after updating your firmware, please contact support.
Posted Oct 07, 2021 - 11:41 CEST
Monitoring
All Ultimaker printers, S-line and the Ultimaker 3, are able to get back online with a firmware upgrade. If your printer is connected to the internet the printer will push a message to the UI which will allow you to upgrade. If the message does not appear, then check the settings menu of the printer. There is no longer a distinction for S5 printers with the robot or U on the side anymore and for the S5 / S3 there is firmware update in both the stable and latest channel. We will be actively monitoring the issue for the coming days.
Posted Oct 05, 2021 - 11:17 CEST
Update
We can now offer a firmware upgrade to get all printers back online into Ultimaker Digital Factory.

We have a firmware update in place for
- Ultimaker S3 printers - both stable (6.2.3) and latest channel (6.5.2)*
- Ultimaker S5 printers with the U on the side - both stable (6.2.3) and latest channel (6.5.2)*
- Ultimaker 3 printers - Version 5.3.0
Make sure the printer is connected to the internet and if need be check the 'Maintenance' menu of the printer to trigger the upgrade.

For S5 printers with the robot on the side we have a firmware release available in the latest channel (6.5.2)*. We are Investigating changes needed for a firmware release for the stable channel. If your Ultimaker S5 is subscribed to to stable firmware changes you can switch firmware channels to get it back online in the Digital Factory. Alternatively, the method of updating the needed certificates manually is also still possible. Paste the URL below in the address bar of your browser to visit an Ultimaker support page containing instructions.
https://support.ultimaker.com/hc/en-us/articles/4407583616018

Ultimaker 2+ Printers remain unaffected.

* A firmware release in the latest channel contains the newest improvements for your Ultimaker printer. A firmware release in the stable channel has features with a thoroughly proven track record in the field. In order to receive one type of release over the other, you need to select the firmware channel in the 'Settings' menu of your printer.
Posted Oct 03, 2021 - 18:22 CEST
Update
Update concerning several types of printers
- We have a firmware in place for S3 printers and S5 printer with the U on the side. Check the maintenance menu of the printer to trigger the upgrade.
- For S5 printers with the robot on the side we have a workaround to get the printers back online. See the link below
https://support.ultimaker.com/hc/en-us/articles/4407583616018
- Our software engineers are working hard on a fix for the UM3 printers.
- Ultimaker 2+ Printers remain unaffected.
Posted Oct 01, 2021 - 23:41 CEST
Update
Unfortunately we are still experiencing a service disruption to Digital Factory. We are in the process of restoring service to our users.

The most common SSL certificate provider (Let’s Encrypt) made changes to how certificates are sent out. Our UM3 and S-line printers are not compatible with these changes.
https://letsencrypt.org/docs/dst-root-ca-x3-expiration-september-2021/

Ultimaker 2+ Connect printers are unaffected.

See detailed instructions to reconnect S-line printers to Digital Factory here
https://support.ultimaker.com/hc/en-us/articles/4407583616018
Posted Oct 01, 2021 - 22:41 CEST
Update
Please be informed that the connection problems still have the fullest attention of the software engineers of our firmware and Digital Factory teams. A fix seems to be at hand.
Posted Oct 01, 2021 - 09:37 CEST
Identified
From around 16:00 up to now we are experiencing a service disruption to Digital Factory. We are in the process of restoring service to our users.

The most common SSL certificate provider (Let’s Encrypt) made changes to how certificates are sent out. Our UM3 and S-line printers are not compatible with these changes.
https://letsencrypt.org/docs/dst-root-ca-x3-expiration-september-2021/

We are working on a new firmware release in order to fix this, but you can manually update the certificates on an S3 / S5 printer
1. For S5 and S3 printers disable the firewall via the printer UI (if you enabled it)
2. Put your printer in development mode. You can enable it in the settings menu. The printer will show its' IP address on the display.
3. Connect to your printer over SSL using putty / command line (windows 10) / terminal
4. Type 'SSH root@ip-address-of-your-printer' and press enter
5. Type 'yes' and press enter to accept the connection
6. Type the password 'ultimaker' and press enter
7. Type 'apt-get update' and press enter. The printer will start to download some packages.
8. Type 'apt-get install ca-certificates' and press enter. The printer will install the new certificates.
9. Type 'reboot' and press enter
10. After reboot enable the firewall again
Posted Sep 30, 2021 - 18:57 CEST
Update
We are continuing to investigate this issue.
Posted Sep 30, 2021 - 17:50 CEST
Investigating
Our printers are unfortunately unable to connect to Digital Factory since the firmwares' root certificate has expired. Our certificate provider is Let's Encrypt, more details about the issue can be found below:
https://letsencrypt.org/docs/dst-root-ca-x3-expiration-september-2021/
We are currently looking for a solution.
Posted Sep 30, 2021 - 17:49 CEST
This incident affected: Cloud Printing - Ultimaker Digital Factory.