Unable to visit Marketplace without logging in
Incident Report for Ultimaker
Resolved
We've resolved the issue. Thank you for your patience.
Posted Jun 17, 2022 - 11:26 CEST
Identified
The Ultimaker Marketplace now requires everyone to log before being able to see materials. Browsing the Marketplace without logging in is currently not possible. We are investigating the issue and are confident it will be resolved soon.
Posted Jun 17, 2022 - 10:22 CEST
This incident affected: Ultimaker Marketplace.